Q:为什么需要内测码?

A:刷机有风险,现在还处于测试阶段;随时可能出问题。只有在你有明确目的的情况下才能建议使用,内测码机制可以筛选掉大部分本不愿意折腾的用户。还可以筛选掉一些连打开个网页复制个标识码都不愿意的伸手党。

Q:为什么需要读取手机信息?

A:实际上,只读取了你的 IMEI 信息。另外,太极除了检查更新,没有任何联网操作;不会收集你的任何信息。不放心的话,禁止太极联网,然后手动更新APP即可。

Q:我有问题,如何反馈?

A:在github上提 issue,注意选择 issue 模版,尽量把问题描述清楚:https://github.com/tiann/EXposed/issues

Q:无法触发 Magisk 版?

A:建议使用 Magisk 17.x 版本。然后检查是否装有其他的 Magisk 模块,如果有请关闭其他模块再尝试。如果确认有冲突,反馈给我:https://github.com/tiann/EXposed/issues

Q:支持哪些模块?

A:原本太极支持的模块都支持,新增支持的模块(边缘手势/核心破解/应用变量/模拟位置/ACEnergy/抖音助手等)在群文件下载即可。

Q:太极与 Xposed 有何不同?

太极的设计理念上与 Xposed 有很多不同:

不强制拦截系统内所有APP,对于不希望使用 Xposed 的 APP ,太极几乎不做任何干涉。

弱侵入特性。太极减少了 Xposed 的很多特征,如 全局的 ClassLoader 中再也没有 Xposed 的身影,非侵入的 app_process 以及弱干涉的 ART。

太极内核可以随时升级,无需重新刷机,直接升级太极 APP 即可完成,可以即为快速地响应和解决 BUG。

当然,受限于 ART 的种种约束,在方法拦截方面,太极无法做到 Xposed 那样完美。有一些方法是无法被拦截的,但是,太极的拦截能力已经足够做出各种功能强大而完善的模块;但是需要开发者在挑选HOOK点的时候额外注意。

Q:为什么有些模块不支持?

因为 rovo89 的 Xposed 压根就不支持 9.0,因此模块都没有适配 9.0 系统。Android 9.0 系统发生了较大的变化,因此这些模块我自己尝试是无法正常工作的,可能导致无法开机,因此无法使用。另外,9.0 的SELinux 规则基本上废掉了 XSharedPreference,严重依赖 XSharedPerference的模块如果 target sdk 为28及以上,那么压根无法工作。

如上所述,Xposed 和 太极的机制实际上是完全不同的,有些模块过分使用了 Xposed 特有的特性(如反射内部类,特殊的成员,外部环境等);这些插件在太极中压根无法运行。

Q:为什么还是有模块限制?

A:实际上,Magisk 版不会对 公开的,非恶意的模块做任何限制;如果你有需要使用的模块,可以直接在本项目的 issue 提交给我。

Q:开放所有模块,能不能用让我们自己测试不就行了?

A:实际上,能折腾并且能理解和体谅开发者的用户凤毛菱角。很多用户(包括会刷机的)甚至连模块在哪里下载都不知道,太极中的模块下载是请求服务器数据的,有段时间服务器挂掉了,有的用户以为是太极 APP 出了问题,卸载重装,刷机,甚至恢复出厂设置。如果冒昧开放所有模块,而其中相当一部分模块无法使用,这些用户只会觉得 APP 垃圾,然后卸载。所以我必须明确告诉他们,哪些模块现在是不行的,哪些模块是可以用的。另外,太极支持免ROOT运行,大量连手机都不怎么会用的用户对我来说就是灾难。

Q:搞两个版本,一个全开,一个限制?

A:这跟只有一个全开的版本没有任何区别。

Q:模块更新就会失效?

A:是的。但是这将不是问题,太极 以后会 Daily Build (每天都更新一个版本);理论上,所有的模块只要有新版,确认可用之后,立马就可以用。

Q:我是开发者,如何适配 太极·Magisk?

A:首先表示欢迎,然后感谢你们的付出。现在可以直接私聊我(以后我会拉开发者群)。

Q:为什么会软重启?

A:是否使用了 太极magisk 模块的 3.6-a,请使用 3.6-b。

Q:为什么模块无法生效?

A:有诸多原因,请逐一检查:

是否需要使用Xposed的APP添加到了太极中?

是否勾选了对应的模块?

某些模块需要重启手机,是否重启过?

某些模块只支持特定版本的APP,APP版本是否正确?

模块版本是否正确?请使用群文件中我上传的已经验证过的模块

注意:太极·Magisk版有一些使用方法与 Xposed 不同,请知悉:

必须把 APP 添加到太极中,太极才会对这个 APP 启用Xposed 功能。

不是作用于系统的模块,无需重启手机即可生效。

模块重新安装之后,需要重新勾选。

Q:为什么无法开机,卡 Logo?

A:请反馈给我,但是暂时可能无法解决;请先使用普通版太极。等我做好了日志模块,后续注意解决。

Q:为什么边缘手势无效?

A:请使用 3.6-a,3.6-b是无法使用的。其次,勾选这个模块之后,需要重启才能使用。

Q:为什么核心破解无法签名覆盖安装?

A:请使用 3.6-a,这个模块还有BUG,暂时只支持降级安装。

Q:为什么会出现阻止闪退?

A:这是太极自带的特性,忽略即可。理论上,如果模块自己没有做好,会导致APP闪退;太极给了APP一个不闪退的机会。并不代表太极本身出现了问题。


版权信息:本站所有资源仅供学习与参考,请勿用于商业用途,如有侵犯您的版权,请及时联系客服,我们将尽快处理。

标 签: 为什么 需要 内测 刷机 风险

上一篇: 如何使用 太极·Magisk ?

下一篇: 注意事项和已知问题

用户评论 (0)

暂无评论

嘿,我来帮您!